Sass problems with Yosemite

diciembre 9, 2014 Reflexiones de la vida Etiquetas: ,

In broken english:

I installed yosemite… and i was very happy using snowleopard

You should not install Yosemite.. or not for now.
When i tried to install compass:

 sudo gem install compass 

this happened:

/usr/bin/compass: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby: bad interpreter: No such file or directory

I tried everything to fix this, but finally i solved this installing Xcode 6.1.1 (sounds weird but this was the only way, believe me).
xcode-osx
I tried all this, this, this and this and the treehouse forum helped me.

Don´t install fucking Yosemite… or wait a couple of months to install it

Then i could install compass correctly and sas but when i tried compass watch –poll this shit came along:

LoadError on line ["54"] of /Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb: cannot load such file -- bootstrap-sass

I use bootrsap but it could be any file

Finally i have to do this to use sass:

  1. Uninstall compass
  2. Install compass 0.12.6: gem install compass -v 0.12.6
  3. And use: bundle exec compass watch –poll instead of simple compass watch –poll
  4. And update to Xcode 6.1.1

Big shout to el guaje Vila who helped me a bunch


AHORA EN CASTELLANO:

Instalé Yosemite…era muy feliz usando Snow Leopard

Empiezo esto recomendando no instalar Yosemite aun, yo lo haría en unos meses cuando compass, sass y el propio Yosemite estén en mejores condiciones para trabajar juntos como buenos colegas que deberían ser.

Cuando me actualicé el sistema operativo, lo primero que hice en terminal fue hacer el viejo y bueno:

 sudo gem install compass 

a lo que me contestó:

/usr/bin/compass: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby: bad interpreter: No such file or directory

Después de dar muchísimas vueltas solucioné esto actualizando la nueva versión de Xcode 6.1.1 (suena raro, pero fue lo único que logró el truco).
xcode-osx
En serio intenté todo esto, esto, esto y esto y muchas cosas de las que me pongo a llorar si las expreso en voz alta, agradezco al foro de treehouse que me dio la solución

Si aun puedes desinstalar Yosemite y seguir con tu vida con el sistema antiguo que usabas te lo recomiendo mucho

Luego que instalé compass instalé sass sin aparente problema y al hacer compass watch –poll me apareció esta mierda:
LoadError on line ["54"] of /Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb: cannot load such file -- bootstrap-sass
Porque uso boostrap para este proyecto pero he visto en los foros gente que le truenan mensajes de todo tipo de archivos

Y al final de probar todo de todo, lo que tuve que hacer fue:

  1. Desinstalar compass
  2. Instalar compass 0.12.6: gem install compass -v 0.12.6
  3. Empezar a usar: bundle exec compass watch –poll
  4. Tener instalado Xcode 6.1.1

yosemite-osx-sass

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Time limit is exhausted. Please reload CAPTCHA.